Frontend Down
resolvedCRITICALaffectedFrontend Testnetlasted 2min 19s
The incident has been resolved
resolved
Jul 2 02:20:02 (UTC)Experiencing issues with Frontend.
investigating
Jul 2 02:17:43 (UTC)The incident has been resolved
Experiencing issues with Frontend.