Perpl Testnet Service Status status page
Incidents

Frontend Down

resolvedCRITICALaffectedFrontend Testnetlasted 1h 20min

The incident has been resolved

resolved
Nov 18 14:33:50 (UTC)

Experiencing issues with Frontend.

investigating
Nov 18 13:13:50 (UTC)
Powered by Checkly