Perpl Testnet Service Status status page
Incidents

Frontend Down

resolvedCRITICALaffectedFrontend Testnetlasted 4min 22s

The incident has been resolved

resolved
Nov 18 15:19:03 (UTC)

Experiencing issues with Frontend.

investigating
Nov 18 15:14:41 (UTC)
Powered by Checkly